]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/objects_eban.nix
Add Eban monitoring
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_eban.nix
diff --git a/modules/private/monitoring/objects_eban.nix b/modules/private/monitoring/objects_eban.nix
new file mode 100644 (file)
index 0000000..659b0ec
--- /dev/null
@@ -0,0 +1,60 @@
+{ ... }:
+let
+  serviceTemplate = rest: {
+    host_name = "eban.bzh";
+    use = "external-web-service";
+    contacts = "eban";
+    contact_groups = "null";
+    check_interval = "15";
+
+    servicegroups = "webstatus-resources";
+  } // rest;
+in
+{
+  contact = {
+    eban = {
+      use = "generic-contact";
+      host_notification_commands = "notify-host-eban-url";
+      service_notification_commands = "notify-service-eban-url";
+    };
+  };
+  host = {
+    "eban.bzh" = {
+      alias = "eban.bzh";
+      address = "eban.bzh";
+      use = "linux-server";
+      hostgroups = "webstatus-hosts";
+      contacts = "eban";
+      contact_groups = "null";
+      _webstatus_name = "Eban";
+      _webstatus_vhost = "status.eban.bzh";
+    };
+  };
+  service = [
+    (serviceTemplate {
+      service_description = "Eban website is up and running";
+      check_command = ["check_https" "eban.bzh" "/" "<title>"];
+      _webstatus_name = "Main Website";
+      _webstatus_url = "https://eban.bzh/";
+    })
+    (serviceTemplate {
+      service_description = "Eban blog is up and running";
+      check_command = ["check_https" "blog.eban.bzh" "/" "<title>"];
+      _webstatus_name = "Blog";
+      _webstatus_url = "https://blog.eban.bzh/";
+    })
+    (serviceTemplate {
+      service_description = "Eban gitea is up and running";
+      check_command = ["check_https" "git.eban.bzh" "/" "<title>"];
+      _webstatus_name = "Git";
+      _webstatus_url = "https://git.eban.bzh/";
+    })
+    (serviceTemplate {
+      service_description = "Eban Cloud is up and running";
+      check_command = ["check_https" "cloud.eban.bzh" "/" "<title>"];
+
+      _webstatus_name = "Cloud";
+      _webstatus_url = "https://cloud.eban.bzh/";
+    })
+  ];
+}