]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add Eban monitoring
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index e79feec573e2273e3471cc3d2f0b362f397173ae..490a4051bf3604b5bd4591d7562ed0395e5e743b 100644 (file)
@@ -558,6 +558,14 @@ in
               };
             };
           };
+          eban = mkOption {
+            description = "Eban credentials for webhook";
+            type = submodule {
+              options = {
+                password = mkOption { type = str; description = "Password"; };
+              };
+            };
+          };
           nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
           slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
           slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };