]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - environments/immae-eu.nix
04a9e9c07fa64c98f982579072a70c4be6929533
[perso/Immae/Config/Nix.git] / environments / immae-eu.nix
1 { pkgs }: with pkgs;
2 let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 paths = [
6 # archives
7 lzo unzip bzip2 xz
8 # unrar is unfree
9
10 # backups
11 duply
12
13 # calendar/contacts
14 abook khard khal cadaver vdirsyncer pal
15
16 # computing
17 boinctui
18
19 # cryptocurrencies
20 cardano cardano-cli sia monero
21 # failing xmr-stak
22 solc
23 iota-cli-app
24
25 # debugging
26 rr valgrind netcat-gnu strace shellcheck
27
28 # documentations
29 unicodeDoc
30
31 # e-mails
32 muttprint mutt-ics
33 notmuch-python2 notmuch-python3 notmuch-vim
34 neomutt mairix
35 bogofilter fetchmail
36 sieve-connect
37
38 # git
39 vcsh gitRepo gitAndTools.stgit tig ripgrep mr
40
41 # graphical tools
42 nextcloud-client firefox
43 dwm dmenu st xorg.xauth tigervnc
44
45 # images
46 feh imagemagick tiv graphicsmagick qrcode
47
48 # internet browsing
49 w3m lynx links elinks browsh weboob urlview urlscan googler urlwatch
50
51 # less
52 python3Packages.pygments lesspipe highlight sourceHighlight
53
54 # monitoring
55 cnagios mtop pg_activity nagios-cli mtr
56 iftop htop iotop iperf bonfire
57 goaccess tcpdump tshark tcpflow
58 mitmproxy
59 # nagnu
60
61 # messaging/forums/news
62 flrn slrn
63 telegram-cli telegram-history-dump telegramircd
64 weechat profanity
65 newsboat irssi
66
67 # nix
68 yarn2nix-moretea.yarn2nix nix
69 nixops nix-prefetch-scripts nix-generate-from-cpan
70 bundix nodePackages.bower2nix nix-diff
71 nodePackages.node2nix niv
72 # (nixos {}).nixos-generate-config
73 # (nixos {}).nixos-install
74 # (nixos {}).nixos-enter
75 # (nixos {}).manual.manpages
76
77 # note taking
78 note terminal-velocity jrnl doing
79
80 # office
81 sc-im ranger
82 genius bc
83 ledger
84 tmux
85 rtorrent
86 ldapvi
87 fzf
88 buku
89 vimPlugins.vim-plug
90 (vim_configurable.override { python = python3; })
91 mailcap
92 webapps.surfer
93
94 # password management
95 (pass.withExtensions (exts: [ exts.pass-otp ])) apg pwgen
96
97 # pdf
98 pdftk poppler_utils
99
100 # programming
101 pelican emacs26-nox ctags
102 wdiff patch gnumake
103
104 # security
105 keybase gnupg
106
107 # todolist/time management
108 taskwarrior vit timewarrior
109
110 # video/music
111 youtube-dl ncmpc ncmpcpp ffmpeg
112
113 # s6 tools (part of skawarePackages)
114 skalibs execline s6 s6-dns s6-linux-utils s6-networking
115 s6-portable-utils
116
117 # system tools
118 telnet bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
119 wget patchelf rename tmux (lib.meta.hiPrio nettools)
120 vlock mosh manpages openssl openssl.doc openssl.man
121 sshfs
122
123 # other tools
124 pgloader s3cmd lftp jq cpulimit libxslt gandi-cli
125
126 # Terraform + AWS
127 terraform_0_12 awscli
128 ansible python3Packages.boto
129 openvpn
130
131 zsh-completions
132 ];
133 in
134 buildEnv {
135 name = "immae-eu-packages";
136 inherit paths;
137 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
138 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
139 passthru = { packages = paths; };
140 }