]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - default.nix
Add some packages and prepare upgrade for nixops
[perso/Immae/Config/Nix.git] / default.nix
1 with import ./libs.nix;
2 with import <nixpkgs> {};
3 let
4 mypkgs = {};
5
6 mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old:
7 fetchedGithub ./fetched/ledger.json // {
8 postInstall = "";
9 }
10 );
11
12 mypkgs.taskwarrior = taskwarrior.overrideAttrs (old: rec {
13 postInstall = ''${old.postInstall}
14 mkdir -p "$out/share/vim/vimfiles/ftdetect"
15 mkdir -p "$out/share/vim/vimfiles/syntax"
16 ln -s "../../../../share/doc/task/scripts/vim/ftdetect/task.vim" "$out/share/vim/vimfiles/ftdetect/"
17 ln -s "../../../../share/doc/task/scripts/vim/syntax/taskrc.vim" "$out/share/vim/vimfiles/syntax/"
18 ln -s "../../../../share/doc/task/scripts/vim/syntax/taskdata.vim" "$out/share/vim/vimfiles/syntax/"
19 ln -s "../../../../share/doc/task/scripts/vim/syntax/taskedit.vim" "$out/share/vim/vimfiles/syntax/"
20 '';
21 });
22
23 mypkgs.vit = (vit.override { taskwarrior = mypkgs.taskwarrior; }).overrideAttrs (old:
24 fetchedGithub ./fetched/vit.json // {
25 buildInputs = old.buildInputs ++ [perlPackages.TryTiny perlPackages.TextCharWidth];
26 }
27 );
28
29 mypkgs.weboob = pythonPackages.weboob.overrideAttrs (old: rec {
30 postInstall = ''${old.postInstall or ""}
31 mkdir -p $out/share/bash-completion/completions/
32 cp tools/weboob_bash_completion $out/share/bash-completion/completions/weboob
33 '';
34 });
35
36 mypkgs.slrn = slrn.overrideAttrs (old: rec {
37 version = "1.0.3a";
38 name = "slrn-${version}";
39 src = fetchurl {
40 url = "http://www.jedsoft.org/releases/slrn/slrn-${version}.tar.bz2";
41 sha256 = "1b1d9iikr60w0vq86y9a0l4gjl0jxhdznlrdp3r405i097as9a1v";
42 };
43 configureFlags = old.configureFlags ++ [ "--with-slrnpull" ];
44 });
45
46 mypkgs.ldapvi = ldapvi.overrideAttrs (old: fetchedGit ./fetched/ldapvi.json);
47
48 nixos = import ./nixos_tools.nix {};
49
50 mypkgs.pass = (pass.withExtensions (exts: [ exts.pass-otp ])).overrideAttrs (old:
51 fetchedGit ./fetched/pass.json // {
52 patches = old.patches ++ [ ./patches/pass-fix-pass-init.patch ];
53 }
54 );
55
56 mypkgs.profanity = (profanity.override {
57 notifySupport = true;
58 inherit libnotify gpgme gdk_pixbuf;
59 python = python3;
60 }).overrideAttrs (old: rec {
61 configureFlags = old.configureFlags ++ [ "--enable-plugins" ];
62 });
63
64 mypkgs.weechat = nixpkgs_unstable.weechat.override {
65 configure = { availablePlugins, ... }: {
66 plugins = with availablePlugins; [
67 (python.withPackages (ps: with ps; [websocket_client emoji]))
68 perl
69 ruby
70 ];
71 };
72 };
73
74 buildPerlPackage = perlPackages.buildPerlPackage;
75 mypkgs.note = buildPerlPackage rec {
76 name = "note-1.3.26";
77 src = fetchurl {
78 url = "mirror://cpan/authors/id/T/TL/TLINDEN/${name}.tar.gz";
79 sha256 = "1h645rnb5vpms48fcyzvp7cwwcbf9k5xq49w2bpniyzzgk2brjrq";
80 };
81 outputs = ["out" "man"];
82 propagatedBuildInputs = [ perlPackages.YAML ];
83 meta = with stdenv.lib; {
84 description = "A perl script for maintaining notes";
85 homepage = http://www.daemon.de/NOTE;
86 license = licenses.gpl3;
87 maintainers = with maintainers; [ { name = "T.v.Dein"; email = "tlinden@cpan.org"; } ];
88 platforms = platforms.unix;
89 };
90 };
91
92 mypkgs.terminal-velocity = with python2Packages; buildPythonApplication rec {
93 pname = "terminal-velocity-git";
94 version = "0.2.0";
95
96 patches = [
97 # FIXME: update this patch when version changes
98 ./patches/terminal_velocity_fix_build.patch
99 ./patches/terminal_velocity_sort_found_notes.patch
100 ];
101
102 propagatedBuildInputs = [ chardet urwid nixpkgs_unstable.python2Packages.sh pyyaml ];
103 buildInputs = [ m2r restructuredtext_lint pygments ];
104
105 postInstall = ''
106 rm $out/bin/terminal_velocity
107 '';
108 src = fetchPypi {
109 inherit pname version;
110 sha256 = "13yrkcmvh5h5fwnai61sbmqkrjyisz08n62pq0ada2lyyqf7g6b9";
111 };
112 };
113
114 mypkgs.mtop = buildPerlPackage rec {
115 name = "mtop-${version}";
116 version = "0.6.6";
117 src = fetchurl {
118 url = "http://downloads.sourceforge.net/project/mtop/mtop/v${version}/mtop-${version}.tar.gz";
119 sha256 = "0x0x5300b1j9i0xxk8rsrki0pspyzj2vylhzv8qg3l6j26aw0zrf";
120 };
121 outputs = ["out"];
122 buildInputs = [ perlPackages.DBI perlPackages.DBDmysql perlPackages.Curses ];
123
124 postInstall = ''
125 cd "$out"
126 preConfigure || true
127 '';
128 meta = with stdenv.lib; {
129 description = "MySQL top (monitor and examine slow queries)";
130 homepage = http://mtop.sourceforge.net/;
131 license = licenses.gpl3;
132 maintainers = with maintainers; [ { name = "Marc Prewitt"; email = "mprewitt@chelsea.net"; } ];
133 platforms = platforms.unix;
134 };
135 };
136
137 mypkgs.tiv = buildPerlPackage rec {
138 name = "tiv-${version}";
139 version = "2015";
140 src = fetchurl {
141 url = "http://xyne.archlinux.ca/projects/tiv/src/tiv-${version}.tar.xz";
142 sha256 = "1vq073v7z7vmcd57lhs4rf4jasji69cpjgkz4dykp94a77p1qq90";
143 };
144 outputs = ["out"];
145 buildInputs = [ perlPackages.PerlMagick ];
146 perlPreHookScript = ./hooks/tiv_builder.sh;
147 perlPreHook = ''
148 source ${perlPreHookScript}
149 '';
150 installPhase = ''
151 install -Dm755 tiv "$out/bin/tiv"
152 '';
153 };
154
155 mypkgs.cnagios = stdenv.mkDerivation (fetchedGithub ./fetched/cnagios.json // rec {
156 configureFlags = [
157 "--with-etc-dir=/etc/cnagios"
158 "--with-var-dir=/var/lib/naemon"
159 "--with-nagios-data=4"
160 ];
161
162 prePatch = ''
163 sed -i -e "s/-lcurses/-lncurses/" Makefile.in
164 '';
165 installPhase = ''
166 install -dm755 $out/share/doc/cnagios
167 install -Dm644 cnagiosrc $out/share/doc/cnagios/
168 install -Dm644 cnagios.help $out/share/doc/cnagios/
169 install -Dm644 cnagios.pl $out/share/doc/cnagios/
170 install -dm755 $out/bin
171 install -Dm755 cnagios $out/bin/
172 '';
173 propagatedBuildInputs = [ perl ncurses ];
174 });
175
176 mypkgs.nagios-cli = python2Packages.buildPythonApplication (fetchedGithub ./fetched/nagios-cli.json);
177
178 mypkgs.pg_activity = with python2Packages; buildPythonApplication (fetchedGithub ./fetched/pg_activity.json // rec {
179 propagatedBuildInputs = [ psycopg2 psutil ];
180 });
181
182 mypkgs.pgloader = stdenv.mkDerivation (fetchedGithub ./fetched/pgloader.json // rec {
183 buildInputs = [ sbcl cacert sqlite freetds libzip curl git openssl makeWrapper ];
184 LD_LIBRARY_PATH = stdenv.lib.makeLibraryPath [ sqlite libzip curl git openssl freetds ];
185 buildPhase = ''
186 export PATH=$PATH:$out/bin
187 export HOME=$TMPDIR
188 make pgloader
189 '';
190 dontStrip = true;
191 enableParallelBuilding = false;
192 installPhase = ''
193 install -Dm755 build/bin/pgloader "$out/bin/pgloader"
194 wrapProgram $out/bin/pgloader --prefix LD_LIBRARY_PATH : "${LD_LIBRARY_PATH}"
195 '';
196 });
197
198 mypkgs.pelican = python3Packages.pelican.overrideAttrs(old: fetchedGithub ./fetched/pelican.json // rec {
199 propagatedBuildInputs = old.propagatedBuildInputs ++ [ python3Packages.pyyaml ];
200 });
201
202 mypkgs.elinks = elinks.overrideAttrs (old:
203 fetchedGithub ./fetched/elinks.json // rec {
204 preConfigure = ''sh autogen.sh'';
205 buildInputs = old.buildInputs ++ [ gettext automake autoconf ];
206 configureFlags = [
207 "--disable-smb" "--without-x" "--enable-cgi"
208 "--enable-leds" "--enable-256-colors"
209 "--enable-html-highlight" "--with-zlib"
210 ];
211 patches = [];
212 }
213 );
214
215 mypkgs.neomutt = neomutt.overrideAttrs (old:
216 rec {
217 buildInputs = old.buildInputs ++ [ gdbm ];
218 configureFlags = old.configureFlags ++ [ "--gdbm" ];
219 }
220 );
221
222 # mypkgs.nagnu = stdenv.mkDerivation (fetchedGithub ./fetched/nagnu.json // rec {
223 # buildInputs = [ ncurses curl ];
224 # installPhase = ''
225 # mkdir -p $out/bin
226 # cp nagnu $out/bin
227 # mkdir -p $out/share/doc/nagnu
228 # cp nagnu.conf.sample $out/share/doc/nagnu
229 # mkdir -p $out/share/man/man8
230 # cp docs/nagnu.8 $out/share/man/man8
231 # '';
232 # });
233
234 mypkgs.goaccess = goaccess.overrideAttrs(old: rec {
235 name = "goaccess-${version}";
236 version = "1.3";
237 src = fetchurl {
238 url = "https://tar.goaccess.io/${name}.tar.gz";
239 sha256 = "16vv3pj7pbraq173wlxa89jjsd279004j4kgzlrsk1dz4if5qxwc";
240 };
241 configureFlags = old.configureFlags ++ [ "--enable-tcb=btree" ];
242 buildInputs = old.buildInputs ++ [ tokyocabinet bzip2 ];
243 });
244
245 mypkgs.mutt-ics = with python3Packages; buildPythonApplication (fetchedGithub ./fetched/mutt-ics.json // rec {
246 propagatedBuildInputs = [ icalendar ];
247 });
248
249 mypkgs.telegram-cli = stdenv.mkDerivation (fetchedGithub ./fetched/telegram-cli.json // rec {
250 patches = [
251 ./patches/telegram-cli.patch
252 ];
253 buildInputs = [ pkgconfig libevent lua jansson openssl readline zlib libconfig ];
254 preBuild = ''
255 sed -i -e 's@"/etc/" PROG_NAME "/server.pub"@"'$out'/etc/server.pub"@' main.c
256 '';
257 installPhase = ''
258 mkdir -p $out
259 install -Dm755 bin/telegram-cli $out/bin/telegram-cli
260 install -Dm644 tg-server.pub $out/etc/server.pub
261 install -Dm644 debian/telegram-cli.8 $out/man/man8/telegram-cli.8
262 '';
263 });
264
265 mypkgs.telegram-history-dump = stdenv.mkDerivation (fetchedGithub ./fetched/telegram-history-dump.json // rec {
266 installPhase = ''
267 mkdir -p $out/lib $out/bin
268 cp -a $src $out/lib/telegram-history-dump
269 ln -s $out/lib/telegram-history-dump/telegram-history-dump.rb $out/bin/telegram-history-dump
270 '';
271 buildInputs = [ ruby ];
272 });
273
274 mypkgs.muttprint = stdenv.mkDerivation rec {
275 name = "muttprint-${version}";
276 version = "0.73";
277 src = fetchurl {
278 url = "http://downloads.sf.net/muttprint/${name}.tar.gz";
279 sha256 = "1dny4niyibfgazwlzfcnb37jy6k140rs6baaj629z12rmahfdavw";
280 };
281 patches = [
282 ./patches/muttprint_0.73-4.diff.gz
283 ./patches/muttprint_regex.patch
284 ./patches/muttprint_two_edge.patch
285 ];
286 preConfigure = ''
287 aclocal
288 automake --add-missing --copy
289 autoconf
290 '';
291 preBuild = ''
292 cd pics
293 convert -flop BabyTuX.eps BabyTuX.eps
294 for i in BabyTuX_color.eps BabyTuX.eps Debian_color.eps \
295 Debian.eps Gentoo.eps Gentoo_color.eps ; do
296 convert $i $(basename $i .eps).png
297 done
298 convert penguin.eps penguin.jpg
299 cd ..
300 '';
301 postInstall = ''
302 perlFlags=
303 for i in $(IFS=:; echo $PERL5LIB); do
304 perlFlags="$perlFlags -I$i"
305 done
306
307 sed -i "$out/bin/muttprint" -e "s|^#\!\(.*[ /]perl.*\)$|#\!\1$perlFlags|"
308 sed -i "$out/bin/muttprint" -e "s|ENV{HOME}/.muttprintrc|ENV{XDG_CONFIG_HOME}/muttprint/muttprintrc|"
309
310 wrapProgram $out/bin/muttprint \
311 --prefix PATH : ${lib.makeBinPath [ psutils dialog
312 (texlive.combine { inherit (texlive) scheme-basic utopia fancyvrb lastpage marvosym ucs cm-super; }) ]}
313 '';
314 buildInputs = [ makeWrapper automake autoconf imagemagick ghostscript perl ] ++
315 (with perlPackages; [ TimeDate FileWhich TextIconv ]);
316 };
317
318 mypkgs.yarn2nix = yarn2nixPackage.yarn2nix;
319
320 mypkgs.cardano = let
321 daedalusOrig = (import (fetchedGithub ./fetched/daedalus.json).src {}).daedalus;
322 cfg = stdenv.mkDerivation rec {
323 name = "launcher-config-custom";
324 src = daedalusOrig.cfg;
325 installPhase = ''
326 cp -a $src $out
327 chmod -R u+w $out
328 cd $out/etc
329 sed -e "/^walletPath/d" -e "/^walletArgs/d" launcher-config.yaml > launcher-config-server-only.yaml
330 '';
331 };
332 daedalus = stdenv.mkDerivation rec {
333 name = "daedalus-custom";
334 src = daedalusOrig;
335 installPhase = ''
336 cp -a $src $out
337 chmod -R u+w $out
338 cd $out/bin
339 sed -i -e "s@${builtins.storeDir}/[0-9a-z]*-daedalus-config@${cfg}/etc@" daedalus
340 sed -e "s@${cfg}/etc/launcher-config.yaml@${cfg}/etc/launcher-config-server-only.yaml@" daedalus > daedalus-server-only
341 chmod a+x daedalus-server-only
342 '';
343 };
344 in
345 daedalus;
346
347 mypkgs.sia = stdenv.mkDerivation rec {
348 version = "v1.3.7";
349 name = "Sia-${version}";
350 src = fetchzip {
351 url = "https://sia.tech/static/releases/${name}-linux-amd64.zip";
352 sha256 = "1ljzwrlkx4hc16r8siiyakn039afipp95dyr83c8yfq3r3bfasqd";
353 };
354 phases = "installPhase";
355 installPhase = ''
356 mkdir -p $out/share/doc
357 mkdir -p $out/bin
358 mkdir -p $out/share/sia
359 cp -a $src/doc $out/share/doc/sia
360 cp -a $src/LICENSE $src/README.md $out/share/sia
361 cp -a $src/{siac,siad} $out/bin
362 cp -a $src/{siac,siad}.sig $out/share/sia/
363 '';
364 };
365
366 mypkgs.iota-cli-app = let
367 nodeEnv = pkgs.callPackage "${nodePackages.node2nix}/lib/node_modules/node2nix/nix/node-env.nix" {
368 nodejs = nodejs-8_x;
369 };
370 # built using node2nix -8 -l package-lock.json
371 # and changing "./." to "src"
372 packageEnv = import ./fetched/iota-cli-app-node-packages.nix {
373 src = stdenv.mkDerivation (fetchedGithub ./fetched/iota-cli-app.json // {
374 phases = "installPhase";
375 installPhase = ''
376 cp -a $src $out
377 chmod u+w -R $out
378 cd $out
379 sed -i -e "s@host: 'http://localhost',@host: 'https://iri.trytes.eu',@" index.js
380 sed -i -e "s@port: 14265@port: 443@" index.js
381 '';
382 });
383 inherit (pkgs) fetchurl fetchgit;
384 inherit nodeEnv;
385 };
386 in
387 packageEnv.package;
388
389 mypkgs.duply = stdenv.mkDerivation rec {
390 name = "duply-${version}";
391 version = "2.1";
392
393 src = fetchurl {
394 url = "mirror://sourceforge/project/ftplicity/duply%20%28simple%20duplicity%29/2.1.x/duply_${version}.tgz";
395 sha256 = "0i5j7h7h6ssrwhll0sfhymisshg54kx7j45zcqffzjxa0ylvzlm8";
396 };
397
398 buildInputs = [ txt2man makeWrapper ];
399
400 postPatch = "patchShebangs .";
401
402 installPhase = ''
403 mkdir -p "$out/bin"
404 mkdir -p "$out/share/man/man1"
405 install -vD duply "$out/bin"
406 sed -i $out/bin/duply -e "1a \
407 export PATH='${stdenv.lib.makeBinPath [ coreutils python2 duplicity gawk gnupg1 bash gnugrep txt2man which ]}'
408 " -e "1a \
409 export DUPL_PYTHON_BIN=$(basename ${duplicity}/lib/python*)
410 "
411 "$out/bin/duply" txt2man > "$out/share/man/man1/duply.1"
412 '';
413
414 meta = with stdenv.lib; {
415 description = "Shell front end for the duplicity backup tool";
416 longDescription = ''
417 Duply is a shell front end for the duplicity backup tool
418 http://duplicity.nongnu.org/. It greatly simplifies it's usage by
419 implementing backup job profiles, batch commands and more. Who says
420 secure backups on non-trusted spaces are no child's play?
421 '';
422 homepage = http://duply.net/;
423 license = licenses.gpl2;
424 maintainers = [ maintainers.bjornfor ];
425 platforms = stdenv.lib.platforms.unix;
426 };
427 };
428
429 mypkgs.boinctui = stdenv.mkDerivation rec {
430 name = "boinctui-${version}";
431 version = "2.5.0";
432 src = fetchurl {
433 url = "http://sourceforge.net/projects/boinctui/files/boinctui_${version}.tar.gz";
434 sha256 = "16zxp8r4z6pllacdacg681y56cg2phnn3pm5gwszbsi93cix2g8p";
435 };
436
437 configureFlags = [ "--without-gnutls" ];
438 preConfigure = ''
439 autoconf
440 '';
441
442 preBuild = ''
443 sed -i -e 's/"HOME"/"XDG_CONFIG_HOME"/' src/cfg.cpp
444 sed -i -e 's@\.boinctui\.cfg@boinctui/boinctui.cfg@' src/mainprog.cpp
445 '';
446 buildInputs = [ expat openssl autoconf ncurses ];
447 };
448
449 mypkgs.sc-im = sc-im.overrideAttrs (old: {
450 buildPhase = ''
451 cd src
452 sed -i Makefile -e 's@\...name.info@.local/state/$(name)info@'
453 cd ..
454 '' + old.buildPhase;
455 });
456
457 mypkgs.notmuch-vim = stdenv.mkDerivation rec {
458 name = "notmuch-vim-${version}";
459 version = nixpkgs_unstable.notmuch.version;
460 outputs = [ "out" ];
461 src = nixpkgs_unstable.notmuch.src;
462 phases = [ "unpackPhase" "installPhase" ];
463 installPhase = ''
464 make -C vim DESTDIR=$out prefix="/share/vim/vimfiles" install
465 '';
466 };
467
468 mypkgs.notmuch-python2 = stdenv.mkDerivation rec {
469 name = "notmuch-python2-${version}";
470 version = nixpkgs_unstable.notmuch.version;
471 outputs = [ "out" ];
472 buildInputs = [ python2Packages.sphinx python2Packages.python ];
473 src = nixpkgs_unstable.notmuch.src;
474 phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ];
475 buildPhase = ''
476 cd bindings/python
477 python setup.py build
478 '';
479 installPhase = ''
480 python setup.py install --prefix=$out --optimize=1
481 '';
482 };
483
484 mypkgs.notmuch-python3 = stdenv.mkDerivation rec {
485 name = "notmuch-python3-${version}";
486 version = nixpkgs_unstable.notmuch.version;
487 outputs = [ "out" ];
488 buildInputs = [ nixpkgs_unstable.python3Packages.sphinx nixpkgs_unstable.python3Packages.python ];
489 src = nixpkgs_unstable.notmuch.src;
490 phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ];
491 buildPhase = ''
492 cd bindings/python
493 python setup.py build
494 '';
495 installPhase = ''
496 python setup.py install --prefix=$out --optimize=1
497 '';
498 };
499
500 mypkgs.telegramircd = with python3Packages; let
501 telethon = buildPythonPackage rec {
502 pname = "Telethon-sync";
503 version = "1.1.1";
504
505 src = fetchPypi {
506 inherit pname version;
507 sha256 =
508 "01z8fzqn0qs5pxhvzq891r3mwffq1ga3f8xvm7qdn6kvmxjni9fy";
509 };
510
511 propagatedBuildInputs = with self; [
512 rsa pyaes async_generator
513 ];
514 doCheck = false;
515
516 meta = with lib; {
517 homepage = https://github.com/LonamiWebs/Telethon;
518 description = "Full-featured Telegram client library for Python 3";
519 license = licenses.mit;
520 };
521 };
522 in
523 buildPythonApplication rec {
524 format = "other";
525 pname = "telegramircd";
526 version = "master";
527 propagatedBuildInputs = [ telethon aiohttp ConfigArgParse openssl ];
528 src = (fetchedGithub ./fetched/telegramircd.json).src;
529 LD_LIBRARY_PATH = "${openssl.out}/lib";
530 installPhase = ''
531 install -D $src/telegramircd.py $out/bin/telegramircd
532 wrapProgram "$out/bin/telegramircd" \
533 --prefix LD_LIBRARY_PATH : "${openssl.out}/lib"
534 install -Dm644 "$src/config" -t "$out/etc/telegramircd/"
535 '';
536 };
537 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
538 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
539 in
540 mypkgs // {
541 inherit nix-prefetch-scripts;
542 inherit nix-generate-from-cpan;
543 inherit timewarrior;
544 inherit pal;
545 inherit pdftk;
546 inherit googler;
547 inherit jrnl;
548 inherit apg pwgen;
549 inherit newsboat;
550 inherit vcsh;
551 inherit xmr-stak;
552 inherit urlwatch;
553 inherit ranger;
554 inherit irssi;
555 inherit abook khard khal;
556 inherit graphicsmagick;
557 inherit youtube-dl;
558 inherit ncmpc ncmpcpp;
559 inherit cadaver;
560 inherit mairix notmuch;
561 inherit ctags;
562 inherit s3cmd;
563 inherit solc; # solidity
564 inherit rtorrent;
565 inherit strace;
566 inherit vdirsyncer;
567 inherit w3m lynx links;
568 inherit gitRepo;
569 inherit valgrind;
570 inherit iotop iperf;
571 inherit keybase;
572 inherit bogofilter;
573 inherit mtr;
574 inherit nixops;
575 inherit urlview;
576 inherit rr;
577 inherit nix-zsh-completions;
578 inherit browsh;
579 inherit monero;
580 inherit nextcloud-client;
581 inherit feh imagemagick;
582 inherit lftp;
583 stgit = gitAndTools.stgit;
584 # todo: lx* ?, unrar, unzip, zeromq?
585 #inherit nextcloud-client;
586 #inherit nixos;
587 } // (with nixpkgs_unstable; {
588 inherit googler;
589 inherit khal;
590 inherit newsboat;
591 inherit xmr-stak;
592 inherit urlwatch;
593 inherit graphicsmagick;
594 inherit ncmpc;
595 inherit solc;
596 inherit w3m lynx links;
597 inherit valgrind;
598 inherit ranger;
599 inherit strace;
600 inherit notmuch notmuch-mutt;
601 stgit = gitAndTools.stgit;
602 inherit bundix;
603 bower2nix = nodePackages.bower2nix;
604 })