]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - default.nix
Continue moving overlays to dedicated directory
[perso/Immae/Config/Nix.git] / default.nix
1 with import <nixpkgs> { overlays = builtins.attrValues (import ./overlays); };
2 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
3 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
4 { # files in overlays/mypkgs.nix
5 inherit boinctui;
6 inherit cnagios;
7 inherit duply;
8 inherit flrn;
9 inherit genius;
10 inherit mtop;
11 inherit muttprint;
12 inherit mutt-ics;
13 inherit nagios-cli;
14 #inherit nagnu;
15 inherit note;
16 inherit notmuch-python2;
17 inherit notmuch-python3;
18 inherit notmuch-vim;
19 inherit pg_activity;
20 inherit pgloader;
21 inherit telegram-cli;
22 inherit telegram-history-dump;
23 inherit telegramircd;
24 inherit terminal-velocity;
25 inherit tiv;
26 inherit unicodeDoc;
27
28 inherit cardano;
29 inherit iota-cli-app;
30 inherit sia;
31 } // { # overlays
32 inherit weboob;
33 inherit taskwarrior;
34 inherit slrn;
35 inherit sc-im;
36 inherit lesspipe;
37 inherit neomutt;
38 inherit weechat;
39 inherit goaccess;
40 inherit profanity;
41 inherit nixops;
42 inherit dwm;
43 inherit vit;
44 inherit pass;
45 inherit elinks;
46 inherit pelican;
47 inherit ldapvi;
48 inherit (mylibs.yarn2nixPackage) yarn2nix;
49 } // {
50 inherit nix-prefetch-scripts;
51 inherit nix-generate-from-cpan;
52 inherit timewarrior;
53 inherit pal;
54 inherit pdftk;
55 inherit googler;
56 inherit jrnl;
57 inherit apg pwgen;
58 inherit newsboat;
59 inherit vcsh;
60 inherit xmr-stak;
61 inherit urlwatch;
62 inherit ranger;
63 inherit irssi;
64 inherit abook khard khal;
65 inherit graphicsmagick;
66 inherit youtube-dl;
67 inherit ncmpc ncmpcpp;
68 inherit cadaver;
69 inherit mairix notmuch;
70 inherit ctags;
71 inherit s3cmd;
72 inherit solc; # solidity
73 inherit rtorrent;
74 inherit strace;
75 inherit vdirsyncer;
76 inherit w3m lynx links;
77 inherit gitRepo;
78 inherit valgrind;
79 inherit iotop iperf;
80 inherit keybase;
81 inherit bogofilter;
82 inherit mtr;
83 inherit urlview;
84 inherit rr;
85 inherit nix-zsh-completions;
86 inherit browsh;
87 inherit monero;
88 inherit nextcloud-client;
89 inherit feh imagemagick;
90 inherit lftp;
91 stgit = gitAndTools.stgit;
92 inherit bundix;
93 bower2nix = nodePackages.bower2nix;
94 inherit firefox;
95 inherit jq;
96 inherit lzo unzip bzip2 p7zip xz;
97 # unrar is unfree
98 inherit tig;
99 inherit emacs26-nox;
100 inherit highlight sourceHighlight;
101 pygmentize = python3Packages.pygments;
102 inherit iftop htop;
103 inherit fetchmail;
104 inherit bc;
105 inherit cpulimit;
106 inherit dmenu st;
107 inherit poppler_utils;
108 inherit tmux;
109 inherit netcat-gnu;
110 inherit ledger;
111 inherit ffmpeg libxslt;
112 }