]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/default.nix
Use flake for openarc
[perso/Immae/Config/Nix.git] / modules / default.nix
CommitLineData
e8864bbf
IB
1let
2 flakeCompat = import ../lib/flake-compat.nix;
3in
996a68c2
IB
4{
5 myids = ./myids.nix;
1a718805 6 secrets = ./secrets.nix;
17f6eae9 7 filesWatcher = ./filesWatcher.nix;
996a68c2 8
9eae2b47 9 webstats = ./webapps/webstats;
7009832a 10 diaspora = ./webapps/diaspora.nix;
742c28ad 11 etherpad-lite = ./webapps/etherpad-lite.nix;
613aea56 12 mastodon = ./webapps/mastodon.nix;
996a68c2 13 mediagoblin = ./webapps/mediagoblin.nix;
d42bbbe6 14 peertube = ./webapps/peertube.nix;
ea3b46ee 15 fiche = ./webapps/fiche.nix;
daf64e3f 16
411af8e3 17 opendmarc = ./opendmarc.nix;
e8864bbf 18 openarc = (flakeCompat ../flakes/openarc).nixosModule;
411af8e3 19
d2e703c5 20 duplyBackup = ./duply_backup;
285380fe 21 rsyncBackup = ./rsync_backup;
3bc32d9e
IB
22 naemon = ./naemon;
23
2e48907d 24 php-application = ./websites/php-application.nix;
5dda316b 25 zrepl = ./zrepl.nix;
daf64e3f 26 websites = ./websites;
581c499c 27} // (if builtins.pathExists ./private then import ./private else {})