]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - flakes/myuids/flake.nix
Move postscript scripts sensible values out of the store
[perso/Immae/Config/Nix.git] / flakes / myuids / flake.nix
CommitLineData
1be9e64b
IB
1{
2 description = "Immae Specific uids";
3
4 outputs = { self }: {
5 lib = {
6 # Check that there is no clash with nixos/modules/misc/ids.nix
7 uids = {
31d99b75 8 postfixscripts = 387;
1be9e64b
IB
9 acme = 388;
10 backup = 389;
11 vhost = 390;
12 openarc = 391;
13 opendmarc = 392;
14 peertube = 394;
15 redis = 395;
16 nullmailer = 396;
17 mediagoblin = 397;
18 diaspora = 398;
19 mastodon = 399;
20 };
21 gids = {
22 nagios = 11; # commented in the ids file
23 acme = 388;
24 backup = 389;
25 vhost = 390;
26 openarc = 391;
27 opendmarc = 392;
28 peertube = 394;
29 redis = 395;
30 nullmailer = 396;
31 mediagoblin = 397;
32 diaspora = 398;
33 mastodon = 399;
34 };
35 };
36 nixosModule = { ... }: {
37 config = {
38 ids.uids = self.lib.uids;
39 ids.gids = self.lib.gids;
40 };
41 };
42 };
43}