]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - environments/immae-eu.nix
Configuration modifications
[perso/Immae/Config/Nix.git] / environments / immae-eu.nix
CommitLineData
8c90ed19 1{ pkgs }: with pkgs;
fdf6f74d
IB
2let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 paths = [
6 # archives
f9914beb 7 lzo unzip bzip2 xz
fdf6f74d
IB
8 # unrar is unfree
9
10 # backups
11 duply
12
13 # calendar/contacts
05a3b252 14 abook khard khal cadaver vdirsyncerStable pal
fdf6f74d
IB
15
16 # computing
17 boinctui
18
19 # cryptocurrencies
6a380f40 20 cardano cardano-cli sia monero
ca5478c6 21 # failing xmr-stak
fdf6f74d
IB
22 solc
23 iota-cli-app
24
25 # debugging
e96787f1 26 rr valgrind netcat-gnu strace shellcheck
fdf6f74d
IB
27
28 # documentations
29 unicodeDoc
30
31 # e-mails
32 muttprint mutt-ics
33 notmuch-python2 notmuch-python3 notmuch-vim
22ba294f 34 neomutt mairix
fdf6f74d 35 bogofilter fetchmail
dc6d3af9 36 sieve-connect
fdf6f74d
IB
37
38 # git
50c100ba 39 vcsh gitRepo gitAndTools.stgit tig ripgrep mr
fdf6f74d
IB
40
41 # graphical tools
42 nextcloud-client firefox
50c100ba 43 dwm dmenu st xorg.xauth tigervnc
fdf6f74d
IB
44
45 # images
054a2da2 46 feh imagemagick tiv graphicsmagick qrcode
fdf6f74d
IB
47
48 # internet browsing
e6052491 49 w3m lynx links elinks browsh weboob urlview urlscan googler urlwatch
fdf6f74d
IB
50
51 # less
52 python3Packages.pygments lesspipe highlight sourceHighlight
53
54 # monitoring
55 cnagios mtop pg_activity nagios-cli mtr
054a2da2 56 iftop htop iotop iperf bonfire
12720877 57 goaccess tcpdump tshark tcpflow
ca5478c6 58 mitmproxy
fdf6f74d
IB
59 # nagnu
60
61 # messaging/forums/news
05a3b252 62 #flrn slrn
fdf6f74d
IB
63 telegram-cli telegram-history-dump telegramircd
64 weechat profanity
65 newsboat irssi
66
67 # nix
b6cc59da 68 yarn2nix-moretea.yarn2nix nix
fdf6f74d 69 nixops nix-prefetch-scripts nix-generate-from-cpan
f5cbc6f7 70 bundix nodePackages.bower2nix nix-diff
ccda44f3 71 nodePackages.node2nix niv
fdf6f74d
IB
72 # (nixos {}).nixos-generate-config
73 # (nixos {}).nixos-install
74 # (nixos {}).nixos-enter
75 # (nixos {}).manual.manpages
76
77 # note taking
50c100ba 78 note terminal-velocity jrnl doing
fdf6f74d
IB
79
80 # office
81 sc-im ranger
82 genius bc
83 ledger
84 tmux
85 rtorrent
86 ldapvi
054a2da2 87 fzf
c31ca68c 88 buku
50c100ba 89 vimPlugins.vim-plug
360b2704 90 (vim_configurable.override { python = python3; })
50c100ba 91 mailcap
91b3d06b 92 webapps.surfer
fdf6f74d
IB
93
94 # password management
6d5ce738 95 (pass.withExtensions (exts: [ exts.pass-otp ])) apg pwgen
fdf6f74d
IB
96
97 # pdf
98 pdftk poppler_utils
99
100 # programming
101 pelican emacs26-nox ctags
50c100ba 102 wdiff patch gnumake
fdf6f74d
IB
103
104 # security
50c100ba 105 keybase gnupg
fdf6f74d
IB
106
107 # todolist/time management
108 taskwarrior vit timewarrior
9970dfe6 109 bugwarrior
fdf6f74d
IB
110
111 # video/music
112 youtube-dl ncmpc ncmpcpp ffmpeg
113
b8951433
IB
114 # s6 tools (part of skawarePackages)
115 skalibs execline s6 s6-dns s6-linux-utils s6-networking
116 s6-portable-utils
117
5138d96c
IB
118 # system tools
119 telnet bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
120 wget patchelf rename tmux (lib.meta.hiPrio nettools)
840812f2 121 vlock mosh manpages openssl openssl.doc openssl.man
f831eb7e 122 sshfs
5138d96c 123
fdf6f74d 124 # other tools
5304a64b 125 pgloader s3cmd lftp jq cpulimit libxslt gandi-cli
e886ea19
IB
126
127 # Terraform + AWS
128 terraform_0_12 awscli
f9914beb 129 ansible python3Packages.boto
e886ea19 130 openvpn
840812f2
IB
131
132 zsh-completions
fdf6f74d
IB
133 ];
134in
8c90ed19
IB
135buildEnv {
136 name = "immae-eu-packages";
137 inherit paths;
138 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
139 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
140 passthru = { packages = paths; };
fdf6f74d 141}