]> git.immae.eu Git - perso/Immae/Config/AUR.git/blob - dwm-git/PKGBUILD
44f68e8425259e843fcd569e7c467c1ca9cf9e40
[perso/Immae/Config/AUR.git] / dwm-git / PKGBUILD
1 pkgname=dwm-git-custom
2 _pkgname=dwm
3 pkgver=6.2_029b988
4 pkgrel=1
5 pkgdesc="A dynamic window manager for X"
6 url="http://dwm.suckless.org"
7 arch=('i686' 'x86_64')
8 license=('MIT')
9 options=(zipman)
10 depends=('libx11' 'libxinerama' 'libxft')
11 makedepends=('git')
12 install=dwm.install
13 provides=('dwm')
14 conflicts=('dwm')
15 epoch=1
16 source=(dwm.desktop
17 "$_pkgname::git+http://git.suckless.org/dwm")
18 md5sums=('939f403a71b6e85261d09fc3412269ee'
19 'SKIP')
20
21 pkgver(){
22 cd $_pkgname
23 echo $(git describe --tags |sed 's/-/./g')_$(md5sum $SRCDEST/config.h | cut -c1-7)
24 }
25
26 prepare() {
27 cd $_pkgname
28 if [[ -f "$SRCDEST/config.h" ]]; then
29 cp -f "$SRCDEST/config.h" config.h
30 fi
31 }
32
33 build() {
34 cd $_pkgname
35 make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
36 }
37
38 package() {
39 cd $_pkgname
40 make PREFIX=/usr DESTDIR="$pkgdir" install
41 install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
42 install -m644 -D README "$pkgdir/usr/share/doc/$pkgname/README"
43 install -m644 -D ../dwm.desktop "$pkgdir/usr/share/xsessions/dwm.desktop"
44 }
45
46 # vim:set ts=2 sw=2 et: